summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2022-04-01 19:33:01 +0200
committerAntonio Rojas2022-04-01 19:33:01 +0200
commit2ffd46ab25fa49b7a5644de50cd53fccc611aa03 (patch)
tree874ab6540b749c0a35abc8b863118fe11598bfcb /PKGBUILD
downloadaur-gnome-search-tool.tar.gz
import from community
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63c6dca0c489
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=gnome-search-tool
+pkgver=3.6.0+82+g4a8f34e
+pkgrel=2
+pkgdesc="Utility to search for files"
+url="https://gitlab.gnome.org/Archive/gnome-search-tool"
+arch=(x86_64)
+license=(GPL2)
+depends=(nautilus libsm)
+makedepends=(intltool yelp-tools git gnome-common)
+_commit=4a8f34e050fb794852264cf54feb7d449dd15965 # master
+source=("git+https://gitlab.gnome.org/Archive/gnome-search-tool.git#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd $pkgname
+
+ # Fix configure
+ sed -i '/^AM_GNU_GETTEXT/d' configure.ac
+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd $pkgname
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+}
+
+check() {
+ make -C $pkgname check
+}
+
+package() {
+ DESTDIR="$pkgdir" make -C $pkgname install
+}
+
+# vim:set ts=2 sw=2 et: