summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonian Guveli2024-03-14 14:50:42 +0200
committerJonian Guveli2024-03-14 14:50:42 +0200
commit13c8fc87754e600b0461358b84a85afc020c0429 (patch)
tree21bb7f27eb228e143fdbc8c60b653daa7aade198 /PKGBUILD
parentbb2662ed991bb5d8dea8d4d5af25cb2bc8d8e46b (diff)
downloadaur-gnome-shell-extension-dash-to-plank.tar.gz
version update to 17
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e220e4716f5f..c80f2b6f1acf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Jonian Guveli <https://github.com/jonian/>
pkgname=gnome-shell-extension-dash-to-plank
-pkgver=16
+pkgver=17
pkgrel=1
pkgdesc="GNOME Shell extension to integrate Plank, the simplest dock on the planet."
arch=("any")
@@ -9,15 +9,16 @@ license=("GPL")
depends=("gnome-shell" "plank")
provides=("gnome-shell-extension-dash-to-plank")
conflicts=("gnome-shell-extension-dash-to-plank-git")
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-md5sums=('5ccc69aa36beda74a2d8ac1c74647e2b')
+source=("$pkgname-$pkgver.zip::$url/releases/download/v$pkgver/dash-to-plank-v$pkgver.zip")
+md5sums=('afc38db9e30ef6fe20b4ad5af2545667')
package() {
- install -d "$pkgdir/usr/share/gnome-shell/extensions" \
- && cp -a "$srcdir/dash-to-plank-$pkgver/dash-to-plank@hardpixel.eu" "$_"
+ rm -f "$srcdir/$pkgname-$pkgver.zip"
+ rm -f "$srcdir/schemas/gschemas.compiled"
+
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/dash-to-plank@hardpixel.eu" \
+ && cp -a "$srcdir/." "$_"
install -d "$pkgdir/usr/share/glib-2.0" \
&& mv "$pkgdir/usr/share/gnome-shell/extensions/dash-to-plank@hardpixel.eu/schemas" "$_"
-
- rm -f "$pkgdir/usr/share/glib-2.0/schemas/gschemas.compiled"
}