summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksandr Mezin2024-03-30 23:51:52 +0200
committerAleksandr Mezin2024-03-30 23:51:52 +0200
commitb0c18da8606d5b9a11599caf9d547cb23e36a067 (patch)
treecb81e79e5c549dec36e5dcb15bd40646246b53c6 /PKGBUILD
parent23c2f73aff829a0e570749c3e2a1101f6ee4da94 (diff)
downloadaur-gnome-shell-extension-ddterm.tar.gz
Update to v54
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 23 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 03c798726f3c..d7d935f275c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,27 @@
-# Maintainer: Amiel Kyamko <junkfactory@gmail.com>
-_uuid=ddterm@amezin.github.com
-_pkgname=ddterm
-pkgname=gnome-shell-extension-$_pkgname
-pkgver=48
-pkgrel=3
-pkgdesc="Another Drop Down Terminal Extension for GNOME Shell"
+# Maintainer: Aleksandr Mezin <mezin.alexander@gmail.com>
+# Contributor: Amiel Kyamko <junkfactory@gmail.com>
+pkgname=gnome-shell-extension-ddterm
+pkgver=54
+pkgrel=1
+pkgdesc='Another Drop Down Terminal Extension for GNOME Shell'
arch=('any')
-url="https://github.com/ddterm/$pkgname"
-license=('GPL3')
-depends=('gnome-shell>=45.0' 'gjs' 'gtk3' 'vte3')
-install=$_pkgname.install
-makedepends=('zip')
-source=($pkgname-v$pkgver.zip::https://github.com/ddterm/gnome-shell-extension-ddterm/releases/download/v$pkgver/ddterm@amezin.github.com.shell-extension.zip)
-sha256sums=('f9d19e5cee226228853b264945967fa41b6d48ba0b6d376c2fe4775a6adfa55e')
+url="https://github.com/ddterm/${pkgname}"
+license=('GPL-3.0-or-later')
+depends=('gnome-shell>=45.0' 'gjs' 'gtk3' 'vte3' 'libhandy')
+install="${pkgname}.install"
+makedepends=('meson' 'git' 'gtk4' 'libxslt' 'xorg-server-xvfb')
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/ddterm/gnome-shell-extension-ddterm/archive/refs/tags/v${pkgver}.tar.gz"
+)
+sha256sums=('42c9fbee87bf6c856a551370877fbea728d766b4056b22c6786428ede88922f6')
+
+build() {
+ arch-meson "${pkgname}-${pkgver}" build
+
+ # gtk-builder-tool needs X or Wayland
+ LIBGL_ALWAYS_SOFTWARE=1 xvfb-run -- meson compile -C build
+}
package() {
- local dest="${pkgdir}/usr/share/gnome-shell/extensions/$_uuid"
- install -d "${dest}"
- bsdtar --no-same-owner -xvf $pkgname-v$pkgver.zip -C "${dest}"
+ meson install -C build --destdir "${pkgdir}"
}