summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonas Gierer2019-04-24 15:51:25 +0200
committerJonas Gierer2019-04-24 15:51:25 +0200
commit93ded140dbaaf62f2401f8b42456af48ebdd8c31 (patch)
tree69cc1c94396f1669b24f752b00d103ca9d7501b6 /PKGBUILD
parentc3859d316614ccaca859bb6d59cd31380031b54e (diff)
downloadaur-gnome-shell-extension-do-not-disturb.tar.gz
v2.0.7-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e29e19e1bfcf..4acebd801935 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,31 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Jonas Gierer <jgierer12@gmail.com>
pkgname=gnome-shell-extension-do-not-disturb
-pkgver=2.0.1
+pkgver=2.0.7
+# Manually update SHA of specified version for now
+# See https://github.com/pop-os/gnome-shell-extension-do-not-disturb/issues/5
+_pkgver_sha=02a6e42607e313777449f83ff775057a28a0861c
pkgrel=1
pkgdesc="Enable or disable do not disturb mode"
arch=(any)
-url="https://github.com/kylecorry31/gnome-shell-extension-do-not-disturb"
+url="https://github.com/pop-os/gnome-shell-extension-do-not-disturb"
license=(MIT)
-depends=(gnome-shell)
+depends=('gjs' 'glib2')
conflicts=(gnome-shell-extension-do-not-disturb-git)
-source=("https://github.com/kylecorry31/gnome-shell-extension-do-not-disturb/archive/v${pkgver}.tar.gz")
-sha256sums=('bfc6c2cf5a9d48e63980d2f1c4394f1daae0baf9371a71f1411577452223c38f')
+source=(
+ "https://github.com/pop-os/gnome-shell-extension-do-not-disturb/archive/${_pkgver_sha}.tar.gz"
+ "https://raw.githubusercontent.com/pop-os/gnome-shell-extension-do-not-disturb/${_pkgver_sha}/LICENSE"
+)
+sha256sums=('a1692eee8e0e3f2c19ebda6e32aa9af982cb7c4f99142fbe414e947741f39b08'
+ '5a2c13b830017acb996f089bf838585c42b221574636b8273392b5c8db8a06af')
build() {
- cd "${pkgname}-${pkgver}"
- make
+ cd "${pkgname}-${_pkgver_sha}"
+ make
}
package() {
- cd "${pkgname}-${pkgver}"
- make DESTDIR="$pkgdir/" install
+ cd "${pkgname}-${_pkgver_sha}"
+ make DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}