summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRubin Simons2025-04-01 15:10:27 +0200
committerRubin Simons2025-04-01 15:10:45 +0200
commit3d96b99144b928465b9a929edb5845fca5321d51 (patch)
tree8db98e96f986c25900b6d7618d8f4335758e6d9d /PKGBUILD
parent7e738c8bc8fc5f097e0a09ebfe5d19008308d4d8 (diff)
downloadaur-gnome-shell-extension-fullscreen-to-new-workspace-git.tar.gz
Corrected install-dir
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53dbd9c59c97..9f22cec31586 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,13 @@
# Maintainer: Joseph DiGiovanni <jdigiovanni78 at gmail dot com>
pkgname=gnome-shell-extension-fullscreen-to-new-workspace-git
+pkgdesc="Fullscreen to New Workspace Gnome Extension (Revived Version)"
pkgver=r53.18faccb
-pkgrel=1
+pkgrel=3
source=("git+https://github.com/corgijan/fullscreen-to-new-workspace.git")
-
sha256sums=(SKIP)
-pkgdesc="Fullscreen to New Workspace Gnome Extension (Revived Version)"
arch=('any')
url="https://github.com/corgijan/fullscreen-to-new-workspace"
license=('GPL3')
@@ -26,12 +25,14 @@ pkgver() {
package() {
cd "${srcdir}/${_pkgname}"
- _uuid='fullscreen-to-empty-workspace@aiono.dev'
+ _uuid="fullscreen-to-empty-workspace2@corgijan.dev"
_install_dir="${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
- install -d ${_install_dir}
+ install -d "${_install_dir}"
cp -r "src/"* -t "${_install_dir}/"
-
- install -Dm644 "src/schemas/org.gnome.shell.extensions.fullscreen-to-empty-workspace.gschema.xml" -t "${pkgdir}/usr/share/glib-2.0/schemas/"
- install -Dm644 "LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ install -Dvm644 "src/schemas/org.gnome.shell.extensions.fullscreen-to-empty-workspace.gschema.xml" -t "${pkgdir}/usr/share/glib-2.0/schemas/"
+ rm -rv "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}/schemas/"
+
+ install -Dvm644 "LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
}