summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorXZS2016-11-01 13:58:21 +0100
committerXZS2016-11-01 13:58:21 +0100
commit421f7cad12baecb925fd0d8b4ae99b0b8f321419 (patch)
tree8d07c40966b4857580af25369246ff042f2a5332 /PKGBUILD
parenta00bb2d75f45037bac3cda2f53c2ef4b30d86d16 (diff)
downloadaur-gnome-shell-extension-maximus-two-git.tar.gz
choose newest extension source
Some extensions authors introduce build steps required before installing. Their execution normally produces a completed variant of the extension code in a subdirectory, difficult to tell apart from the original source. The find condition introduced herein proves the process against such cases to come. It always chooses the files created last, ensuring that a build which occurred after mere unpacking will always take precedence.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0152bd07c1e1..74920f5c1ed3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,7 +35,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}