summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2018-08-30 04:58:52 +0430
committerMohammadreza Abdollahzadeh2018-08-30 04:58:52 +0430
commit9341e3729d5f368de0d249802e492214485f4482 (patch)
tree93e6b9f92cc92278d5311ccc004f90541f6da799 /PKGBUILD
parent56246632eca14635ec9d57d163b6939fa2ed3cc8 (diff)
downloadaur-gnome-shell-extension-panel-osd-git.tar.gz
change upstream url
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98f31d350925..9af4a9d0e39b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,42 @@
-# Maintainer: Edgard Castro <castro@edgard.org>
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+# Contributor: Edgard Castro <castro@edgard.org>
# Contributor: Carl George < arch at cgtx dot us >
# Contributor: Tamás Barta < barta dot tamas dot d at gmail dot com >
pkgname=gnome-shell-extension-panel-osd-git
-pkgver=r113.c33034a
+pkgver=1.0.r45.geb0d3c2
pkgrel=1
pkgdesc='Place gnome-shell notifications under the panel instead of above the message-tray. (git version)'
arch=(any)
_githubname=gnome-shell-extension-panel-osd
_githubowner=jenslody
-url="https://github.com/${_githubowner}/${_githubname}"
+url="https://gitlab.com/${_githubowner}/${_githubname}"
license=(GPL3)
depends=('gnome-shell')
makedepends=("gnome-common" "automake" "autoconf" "intltool" "pkg-config")
-source=("git+https://github.com/${_githubowner}/${_githubname}.git")
-sha256sums=('SKIP')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
+install='gnome-shell-extension.install'
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
pkgver() {
- cd "${srcdir}/${_githubname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${srcdir}/${_githubname}"
+ #printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_githubname}"
- ./autogen.sh --prefix=/usr
- make
+ cd "${srcdir}/${_githubname}"
+ ./autogen.sh --prefix=/usr
+ make
}
package() {
- cd "${srcdir}/${_githubname}"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${_githubname}"
+ make DESTDIR="$pkgdir" install
}
+# vim:set ts=2 sw=2 et: