summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrancoism902022-09-18 12:59:08 +0200
committerfrancoism902022-09-18 12:59:08 +0200
commitc61eed0c9f4170b24398bb80299862280ff37e5b (patch)
treeadc081de7d96be9cebd5426d01668644576e4281 /PKGBUILD
parent48300602d57573115669d6c753b91927a9b35f74 (diff)
downloadaur-gnome-shell-extension-status-area-horizontal-spacing.tar.gz
v2.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 18 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c997090e09f3..ac5832fa598a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,28 @@
-# Maintainer: Alex S. shantanna_at_hotmail_dot_com>
+# Maintainer: Francois Menning <f.menning@pm.me>
+# Contributer: Alex S. shantanna_at_hotmail_dot_com>
pkgname=gnome-shell-extension-status-area-horizontal-spacing
-pkgver=2.6
+pkgver=2.8
pkgrel=1
-pkgdesc="This is a GNOME shell extension that reduces the horizontal spacing between status area icons (top-right of the panel: volume indicator, etc)."
+pkgdesc="Reduces the horizontal spacing between icons/indicators in the status area"
arch=('any')
-url="https://gitlab.com/p91paul/status-area-horizontal-spacing-gnome-shell-extension"
-license=('unknow')
+url="https://gitlab.com/p91paul/status-area-horizontal-spacing-gnome-shell-extension.git"
+license=('custom')
depends=('gnome-shell')
-source=('git+https://gitlab.com/p91paul/status-area-horizontal-spacing-gnome-shell-extension.git')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname}::git+${url}#tag=v2.8")
sha256sums=('SKIP')
-package() {
- _uuid='status-area-horizontal-spacing@mathematical.coffee.gmail.com'
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make all
+}
- cd status-area-horizontal-spacing-gnome-shell-extension
- make
- install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+package() {
+ cd "$srcdir/${pkgname%-git}"
- cp -af "${_uuid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
+ install -dm755 "${pkgdir}/usr/share/gnome-shell/extensions"
+ cp -a "status-area-horizontal-spacing@mathematical.coffee.gmail.com" "${pkgdir}/usr/share/gnome-shell/extensions"
}