summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorotaj2023-02-16 11:42:18 +0100
committerotaj2023-02-16 11:42:18 +0100
commitf283c7b9491e51d434681ff379ce11d358c46883 (patch)
tree5c5693bf2d55982a0c166644899187adf80bd90f /PKGBUILD
parent6f22900e44d542f211ad0751231bf1ec5ac36e85 (diff)
downloadaur-gnome-shell-extension-todotxt-git.tar.gz
fixing the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c02d6ec1af5b..41e7d2beb6ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gnome-shell-extension-todotxt-git
_pkgname="${pkgname%-*}"
_pkgdir=todo-txt
-pkgver=39.r5.gf61feb3
+pkgver=39.r11.gcc29307
pkgrel=1
pkgdesc="Todo.txt GUI for gnome-shell. Git version"
arch=('any')
@@ -29,7 +29,8 @@ pkgver() {
build() {
cd "$srcdir/${_pkgdir}"
python tools/json2schema.py
- python preferences/createPrefsTemplate.py
+ python preferences/createPrefsTemplate.py
+ glib-compile-schemas schemas
jq '.version="'${pkgver}'"' metadata.json | sponge metadata.json
}
@@ -37,9 +38,9 @@ package() {
cd "${_pkgdir}"
_extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
_destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
- for f in `cat dist_files.lst` ; do
- if [ ! -d $f ] ; then
- install -DTm 644 $f ${_destdir}/$f;
+ while IFS= read -r f ; do
+ if [ ! -d "$f" ] ; then
+ install -DTm 644 "$f" "${_destdir}/$f"
fi
- done
+ done < tools/dist_files.lst
}