summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Edson2022-01-18 07:33:38 -0800
committerJason Edson2022-01-18 07:38:10 -0800
commit5c2aff05f6b87869bfb46563c7b2b7bfe0d7e9cf (patch)
tree273ae890572f7592990db217010bbc97267c7030 /PKGBUILD
parentc90c16c28f9a0452e4a2c5cb779d6c9bd37b9032 (diff)
downloadaur-5c2aff05f6b87869bfb46563c7b2b7bfe0d7e9cf.tar.gz
Temporarily add local patch to fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1f0f6a147070..7236efd4d8da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgname='gnome-terminal'
pkgname="${_pkgname}-fedora"
pkgver=3.42.2
-pkgrel=1
+pkgrel=2
pkgdesc='The GNOME Terminal Emulator with Fedora patches'
url='https://wiki.gnome.org/Apps/Terminal'
license=('GPL')
@@ -38,16 +38,21 @@ _fgsoverridefile='org.gnome.Terminal.gschema.override'
source=("https://download.gnome.org/sources/${_pkgname}/${pkgver::4}/${_pkgname}-${pkgver}.tar.xz"
"${_fpatchfile100}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile100}"
"${_fgsoverridefile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fgsoverridefile}"
+ "0001-Fix-build-with-latest-meson.patch"
)
sha256sums=('8a9c8e5ef7a3a73b246a947e1190bb08ec98935af860cf0b3aa2fbf4606817a0'
'0b6adf6f8ec31c88044c349fe0e6d10a3cfce96896fd8a655a547fd55ca33838'
- 'a4a22834d6524fb697a8edf91c9489617d5ab2e513413fc84c6b8575320938f9')
+ 'a4a22834d6524fb697a8edf91c9489617d5ab2e513413fc84c6b8575320938f9'
+ 'f67d28346b2ea612a1633c40e2b120f6bebf20d68202330ab6446d4d9d71c94f')
prepare () {
cd "${_pkgname}-${pkgver}"
# Apply patches
patch -p1 -i "../${_fpatchfile100}-${_fcommit}"
+
+ # Apply meson patch until fixed upstream
+ patch -p1 -i "../0001-Fix-build-with-latest-meson.patch"
}
build() {