summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJason Edson2022-08-09 06:04:21 -0700
committerJason Edson2022-08-09 06:44:39 -0700
commitf0bd41ddaec15aa91259f29e8d8b009b81f60ae9 (patch)
tree6d8e3a001dd15b04b5c0beec6214db6e8cfcdbfe /PKGBUILD
parent1be93a60df2f8eb574232c24ed4274b8d7da1bf1 (diff)
downloadaur-f0bd41ddaec15aa91259f29e8d8b009b81f60ae9.tar.gz
Change source to git and use version tags
Also clean up the PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 43 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c0a3327b27af..4ef0e0839b1b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Davi da Silva Böger <dsboger@gmail.com>
+# Maintainer: Jason Edson <jaysonedson@gmail.com>
+# Contributor: Davi da Silva Böger <dsboger@gmail.com>
# Contributor: Manuel Hüsers <manuel.huesers@uni-ol.de>
# Contributor: Fernando Fernandez <fernando@softwareperonista.com.ar>
# Contributor: Jan de Groot <jgc@archlinux.org>
-# Contributor: Jason Edson <jaysonedson@gmail.com>
_pkgname='gnome-terminal'
pkgname="${_pkgname}-fedora"
@@ -11,18 +11,26 @@ pkgrel=1
pkgdesc='The GNOME Terminal Emulator with Fedora patches'
url='https://wiki.gnome.org/Apps/Terminal'
license=('GPL')
-arch=('i686'
- 'x86_64')
-depends=('vte3-notification>=0.68.0'
- 'gsettings-desktop-schemas')
-makedepends=('git'
- 'docbook-xsl'
- 'libnautilus-extension'
- 'gnome-shell'
- 'meson'
- 'yelp-tools')
-optdepends=('gconf: for gnome-terminal-migration'
- 'libnautilus-extension: for "Open Terminal Here" in GNOME Files')
+arch=(
+ 'i686'
+ 'x86_64'
+)
+depends=(
+ 'vte3-notification>=0.68.0'
+ 'gsettings-desktop-schemas'
+)
+makedepends=(
+ 'git'
+ 'docbook-xsl'
+ 'libnautilus-extension'
+ 'gnome-shell'
+ 'meson'
+ 'yelp-tools'
+)
+optdepends=(
+ 'gconf: for gnome-terminal-migration'
+ 'libnautilus-extension: for "Open Terminal Here" in GNOME Files'
+)
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
options=('!emptydirs')
@@ -35,33 +43,36 @@ _fcommit='f861af05934c00673324840140004b0a5c9197f7'
_fpatchfile100='gnome-terminal-cntr-ntfy-autottl-ts.patch'
_fgsoverridefile='org.gnome.Terminal.gschema.override'
-source=("https://download.gnome.org/sources/${_pkgname}/${pkgver::4}/${_pkgname}-${pkgver}.tar.xz"
- "${_fpatchfile100}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile100}"
- "${_fgsoverridefile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fgsoverridefile}"
+source=(
+ "git+https://gitlab.gnome.org/GNOME/gnome-terminal.git#tag=${pkgver}"
+ "${_fpatchfile100}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fpatchfile100}"
+ "${_fgsoverridefile}-${_fcommit}::${_frepourl}/raw/${_fcommit}/f/${_fgsoverridefile}"
+)
+sha256sums=(
+ 'SKIP'
+ 'cf8c1ccc822e7198bf9a9598b7e0cc3c958c542ba138a5874302b730f0d76eec'
+ 'a4a22834d6524fb697a8edf91c9489617d5ab2e513413fc84c6b8575320938f9'
)
-sha256sums=('fb6f20ee1ff231a9aaedab13d5dc6e5a64c955711224848b790086e88959d37b'
- 'cf8c1ccc822e7198bf9a9598b7e0cc3c958c542ba138a5874302b730f0d76eec'
- 'a4a22834d6524fb697a8edf91c9489617d5ab2e513413fc84c6b8575320938f9')
prepare () {
- cd "${_pkgname}-${pkgver}"
+ cd ${_pkgname}
- # Apply patches
- patch -p1 -i "../${_fpatchfile100}-${_fcommit}"
+ # Apply patches
+ patch -p1 -i "../${_fpatchfile100}-${_fcommit}"
}
build() {
- arch-meson build gnome-terminal-${pkgver} \
- -D b_lto=false \
- -D docs=true \
- -Dnautilus_extension=true \
- -Dsearch_provider=true
- meson compile -C build
+ arch-meson build gnome-terminal \
+ -D b_lto=false \
+ -D docs=true \
+ -Dnautilus_extension=true \
+ -Dsearch_provider=true
+ meson compile -C build
}
package() {
- meson install -C build --destdir "$pkgdir"
+ meson install -C build --destdir "${pkgdir}"
- install -Dm644 "$srcdir/${_fgsoverridefile}-${_fcommit}" \
- "${pkgdir}/usr/share/glib-2.0/schemas/${_fgsoverridefile}"
+ install -Dm644 "${srcdir}/${_fgsoverridefile}-${_fcommit}" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/${_fgsoverridefile}"
}