summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorvinszent2017-10-14 13:37:47 +0200
committervinszent2017-10-14 13:37:47 +0200
commitaaaa8dbc83da880bbc0e7550562632bb8cb9d3bb (patch)
tree4cd1ffe40833fa01a14c03fe98f03233d6f47475 /PKGBUILD
parent48865ea7a2f096434bdd55f76bc7764caeccd57d (diff)
downloadaur-gnome-twitch-player-backend-gstreamer-opengl.tar.gz
Patch typo in Meson options
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4bcd957f44e3..98ec68d93b28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,25 @@
_gitname=gnome-twitch
pkgname=gnome-twitch-player-backend-gstreamer-opengl
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc="GStreamer OpenGL (hardware rendering) player backend for GNOME Twitch"
arch=('i686' 'x86_64')
url="https://github.com/vinszent/gnome-twitch"
license=('GPL3')
makedepends=('git' 'meson')
depends=('gnome-twitch' 'gtk3' 'gstreamer' 'gst-libav' 'gst-plugins-base' 'gst-plugins-good' 'gst-plugins-bad' 'libpeas' 'gobject-introspection')
-source=("https://github.com/Ippytraxx/gnome-twitch/archive/v${pkgver}.tar.gz")
-md5sums=('42abec672144865828a9eb4764037a3a')
+source=("https://github.com/Ippytraxx/gnome-twitch/archive/v${pkgver}.tar.gz"
+ "0001-Fix-typo-in-Meson-build-options.patch")
+md5sums=('42abec672144865828a9eb4764037a3a'
+ '9efc76e74fbfd6ca20a2b474b0980002')
conflicts=('gnome-twitch-player-backend-gstreamer-opengl-git')
+prepare()
+{
+ cd "${_gitname}-${pkgver}"
+ patch -p1 -i ../0001-Fix-typo-in-Meson-build-options.patch
+}
+
build()
{
cd "${_gitname}-${pkgver}"