summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Blakeney2024-03-13 14:19:49 +1000
committerMark Blakeney2024-03-13 14:19:49 +1000
commit5da0d5e3621433b4ff8d2a1158365cf14d4ed2bb (patch)
treeb980b97d9c6484953af48daaa08981beee8c3c3c /PKGBUILD
parentd2739b9db88e136d4881fa27e6b172a1ffd1a92c (diff)
downloadaur-gnucash-asx-fetch.tar.gz
Update to 1.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd1449ae270e..c0e779b06795 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=gnucash-asx-fetch
-pkgver=1.5
+pkgver=1.6
pkgrel=1
pkgdesc="Utility to fetch and add current ASX prices to one or more gnucash XML files"
url="https://github.com/bulletmark/$pkgname"
license=(GPL3)
arch=(any)
-depends=("python>=3.6")
-makedepends=(python-setuptools python-build python-installer python-wheel)
+depends=("python>=3.6" "python-yfinance")
+makedepends=(python-setuptools python-build python-installer
+ python-wheel python-setuptools-scm)
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha1sums=('8db2ae38705ffc6935382006eb3c383493bd5492')
+sha1sums=('3f06f570a91267c7eb8413780197fb01b13050fb')
build() {
cd "$srcdir/$pkgname-$pkgver"
- python -m build --wheel --no-isolation
+ SETUPTOOLS_SCM_PRETEND_VERSION="$pkgver" python -m build --wheel --no-isolation
}
package() {