summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStorm Dragon2016-11-14 14:12:48 -0500
committerStorm Dragon2016-11-14 14:12:48 -0500
commit5226e0a5b2bf271587213543ef10c4e3cb69fd17 (patch)
treea2a1012b784d6619542de94d4bf99e8cfc0f87c3 /PKGBUILD
parent1070cc6d938de731e6d85bb5b5ac850d5f4f598b (diff)
downloadaur-gnusocialshell-git.tar.gz
Updated PKGBUILD to work with new compilation methods.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28a54aae13fc..813305460093 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Storm Dragon <stormdragon2976@gmail.com>
_pkgname="GnuSocialShell"
pkgname="gnusocialshell-git"
-pkgver=.
-pkgrel=1
+pkgver=0.2
+pkgrel=2
pkgdesc="A simple useful text-based GnuSocial client to UNIX-like Operating Systems"
arch=('armv7h' 'i686' 'x86_64')
url="https://github.com/dalmemail/GnuSocialShell"
@@ -14,15 +14,14 @@ conflicts=("gss")
source=("git+${url}.git")
md5sums=("SKIP")
-pkgver()
-{
- cd "$_pkgname"
- git shortlog | tail -n2 | tr -Cd "[:digit:].-"
-}
-
+# Needs a pkgver function but none of the ones I try work, there are no tags and the tagless code only generates a . which causes an error.
+
build()
{
cd "$_pkgname"
+ touch config.rpath
+ autoreconf -iv
+ ./configure --prefix=/usr/local
make
}