summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeremy Audet2019-09-22 12:52:35 -0400
committerJeremy Audet2019-09-22 12:52:35 -0400
commit0d78e4df5ccafebf9fc9f8ea4c520a8956accf87 (patch)
treefd2923bd07d5869a25993acc3e822868ceb8e059 /PKGBUILD
parent3cd8fe25c9d25a05c7e78073aad5b41055d35d34 (diff)
downloadaur-gog-jotun.tar.gz
Update to version 20190912
The source filename is `jotun_12_09_2019_32415.sh`. This appears to be in the form `jotun_dd_mm_yyyy_timestamp.sh`, and an unfortunate side-effect of this issue is that newer package versions don't play well with `vercmp`'s version comparison logic. Consequently, this PKGBUILD does some work to separate the date-based version (20190912) from the filename.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe9ffa5eebae..ff7a01ae120b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# - https://github.com/Sude-/lgogdownloader
pkgname='gog-jotun'
-pkgver='20190430_29317'
+pkgver='20190912'
pkgrel=1
pkgdesc='Jotun is a hand—drawn action—exploration game set in Norse mythology.'
url='http://jotungame.com/'
@@ -17,13 +17,11 @@ arch=('i686' 'x86_64')
source=(
"${pkgname}"
"${pkgname}.desktop"
- "file://jotun_${pkgver}.sh"
-)
-sha256sums=(
- '8a99b6c941c309af11a3d251280562d0729dad74667dabe5d654530aa9064410'
- 'c68e6416957174c6194b4d38d773b122a635a8e4579b69c995c8f2709cb77840'
- '0ca6c3941e0bec757c4b2306f1800fa7591b5305520025ab34646adbaf828912'
+ "file://jotun_${pkgver:6:2}_${pkgver:4:2}_${pkgver:0:4}_32415.sh"
)
+sha256sums=('8a99b6c941c309af11a3d251280562d0729dad74667dabe5d654530aa9064410'
+ 'c68e6416957174c6194b4d38d773b122a635a8e4579b69c995c8f2709cb77840'
+ '160dcd29253349b0f84c0a03d49fe41cd50319f58ce48df025135733c16c779b')
package() {
install -d "${pkgdir}/opt/${pkgname}/"