summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorruniq2017-01-28 18:17:28 +0100
committerruniq2017-01-28 18:17:28 +0100
commit580c706f079fa4fa1390df42fef92cb8d679358f (patch)
tree3b2b3aef1d8320a5cd7d415f6769725ae9a72389 /PKGBUILD
downloadaur-gog-sublevel-zero.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5cc46d3c0965
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Patrice Peterson <runiq@archlinux.us>
+# Thanks to: Ainola for the base PKGBUILD (gog-undertale)
+
+pkgname=gog-sublevel-zero
+pkgver=2.1.0.2
+pkgrel=1
+pkgdesc="First-person roguelike six-degree-of-freedom shooter set in a universe where reality is falling apart"
+url="http://www.sigtrapgames.com/sublevelzero"
+license=('custom')
+arch=('i686' 'x86_64')
+# If Firejail is installed, this application will be sandboxed automatically.
+optdepends=('firejail: Automatically sandbox this application from your OS')
+source=(
+ "gog://${pkgname//-/_}_${pkgver}.sh"
+ "${pkgname}.desktop"
+ "$pkgname")
+sha256sums=('0464056ab98d22f36f65fce35db9c97fe4e912eab4d6ba5063a836ee26d5d0de'
+ '2d3883161f411121db39d16792b53b5e21f90a35ff9166a10d4e09fc553339a4'
+ '6f7b930ac2abb0866793d6f1e850ba759f919bc6762561a1a3b9080586f035cb')
+
+# You need to download the gog.com installer file manually or with lgogdownloader.
+DLAGENTS+=("gog::/usr/bin/echo %u Download the GOG file to \"$PWD\" or set up a gog:// DLAGENT.")
+
+# Prevent compressing final package
+PKGEXT=".pkg.tar"
+
+package(){
+ cd "${srcdir}"
+
+ # Install game
+ install -d "${pkgdir}/opt/${pkgname}/"
+ install -d "${pkgdir}/opt/${pkgname}/support"
+ install -d "${pkgdir}/usr/bin/"
+ cp -r "data/noarch/game/" "${pkgdir}/opt/${pkgname}/"
+
+
+ find "${pkgdir}/opt/${pkgname}" -type d -exec chmod 755 {} \;
+ install -Dm755 "data/noarch/start.sh" \
+ "${pkgdir}/opt/${pkgname}/"
+ install -Dm755 data/noarch/support/*.{sh,shlib} -t \
+ "${pkgdir}/opt/${pkgname}/support"
+
+ # Desktop integration
+ install -Dm 644 "data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm755 "$srcdir/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}