summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyndair2024-02-12 21:13:13 +0000
committerkyndair2024-02-12 21:13:13 +0000
commitba160b756db0fb13b74dcfa46aeae74fea21d486 (patch)
treeb3e5ce0d849e225ee2d1db53b631fecdcbc7f146 /PKGBUILD
downloadaur-gog-surviving_mars_digital_deluxe_edition_upgrade_pack.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb4f37daeba6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: kyndair <kyndair at gmail dot com>
+# Place the gog installation file in the same folder as this PKGBUILD
+# the installer will warn that the folder may not be correct, this can be ignored
+pkgname=gog-surviving_mars_digital_deluxe_edition_upgrade_pack
+_dlcparent=surviving_mars
+_pkgname=surviving_mars_digital_deluxe_edition_upgrade_pack
+pkgver=1.5_fuglesang_1011166
+_pkgver=1_5_fuglesang_1011166
+_build=55908
+pkgrel=1
+pkgdesc="DLC for the $(echo ${_dlcparent} | sed 's/_/ /g') game."
+arch=('x86_64')
+url="https://www.gog.com/en/game/${_pkgname}"
+license=('custom')
+depends=($(echo gog-${_dlcparent}))
+source=("${_pkgname}_${_pkgver}_${_build}.sh::gog://${_pkgname}_${_pkgver}_${_build}.sh")
+# don't download anything via makepkg
+DLAGENTS+=("gog::/usr/bin/perl -E print\(\"${RED}\"\ .\ substr\(\"%u\",\ 6\)\ .\ \"\ not\ found.\ \ Check\ the\ PKGBUILD\ for\ further\ information.${ALL_OFF}\\\\n\"\)\;\ exit\ 1")
+sha256sums=('851b764d6bbeeace62b92c8863cfb52ea38ad0ad165a8db2b6291f89ccc5435c')
+noextract=("${_pkgname}_${_pkgver}_${_build}.sh")
+
+prepare() {
+ chmod +x ${_pkgname}_${_pkgver}_${_build}.sh
+ ./${_pkgname}_${_pkgver}_${_build}.sh -- --silent --destination="${srcdir}"
+}
+
+package() {
+ # install game documents
+ install -Dm644 "${srcdir}/docs/"*"/End User License Agreement.txt" "${pkgdir}/usr/share/doc/${_pkgname}/EULA"
+ install -Dm644 "${srcdir}/docs/"*"/installer_readme.txt" "${pkgdir}/usr/share/doc/${_pkgname}/installer.readme"
+ # install game data, executable and link in /usr/bin
+ find "${srcdir}/game" -type d -exec chmod 755 {} +
+ find "${srcdir}/game" -type f -exec chmod 644 {} +
+ mkdir -p "${pkgdir}/opt/${_dlcparent}"
+ mv "${srcdir}/game/"* "${pkgdir}/opt/${_dlcparent}"
+}