summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyndair2024-02-12 21:14:14 +0000
committerkyndair2024-02-12 21:14:14 +0000
commit85f24bdef584ce2c68c92d0cc41c242f1e7dcdd6 (patch)
tree6d8d985956803ba6a48c9302f279e55429e8a0fb /PKGBUILD
downloadaur-gog-surviving_mars_mysteries_resupply_pack.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8220f6755ff9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: kyndair <kyndair at gmail dot com>
+# Place the gog installation file in the same folder as this PKGBUILD
+# the installer will warn that the folder may not be correct, this can be ignored
+pkgname=gog-surviving_mars_mysteries_resupply_pack
+_dlcparent=surviving_mars
+_pkgname=surviving_mars_mysteries_resupply_pack
+pkgver=1.5_fuglesang_1011166
+_pkgver=1_5_fuglesang_1011166
+_build=55908
+pkgrel=1
+pkgdesc="DLC for the $(echo ${_dlcparent} | sed 's/_/ /g') game."
+arch=('x86_64')
+url="https://www.gog.com/en/game/${_pkgname}"
+license=('custom')
+depends=($(echo gog-${_dlcparent}))
+source=("${_pkgname}_${_pkgver}_${_build}.sh::gog://${_pkgname}_${_pkgver}_${_build}.sh")
+# don't download anything via makepkg
+DLAGENTS+=("gog::/usr/bin/perl -E print\(\"${RED}\"\ .\ substr\(\"%u\",\ 6\)\ .\ \"\ not\ found.\ \ Check\ the\ PKGBUILD\ for\ further\ information.${ALL_OFF}\\\\n\"\)\;\ exit\ 1")
+sha256sums=('b3ce1f9f33ad75d02c8b31f5ba9c0742d92fcbd90ab1c2a48a306a86e18de617')
+noextract=("${_pkgname}_${_pkgver}_${_build}.sh")
+
+prepare() {
+ chmod +x ${_pkgname}_${_pkgver}_${_build}.sh
+ ./${_pkgname}_${_pkgver}_${_build}.sh -- --silent --destination="${srcdir}"
+}
+
+package() {
+ # install game documents
+ install -Dm644 "${srcdir}/docs/"*"/End User License Agreement.txt" "${pkgdir}/usr/share/doc/${_pkgname}/EULA"
+ install -Dm644 "${srcdir}/docs/"*"/installer_readme.txt" "${pkgdir}/usr/share/doc/${_pkgname}/installer.readme"
+ # install game data, executable and link in /usr/bin
+ find "${srcdir}/game" -type d -exec chmod 755 {} +
+ find "${srcdir}/game" -type f -exec chmod 644 {} +
+ mkdir -p "${pkgdir}/opt/${_dlcparent}"
+ mv "${srcdir}/game/"* "${pkgdir}/opt/${_dlcparent}"
+}