summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbegin-theadventure2023-10-12 15:14:16 +0200
committerbegin-theadventure2023-10-12 15:14:16 +0200
commitca963682cd3508dd8378c836afa0bd50b3d461f3 (patch)
tree2c79d8948fec37662a04c783b79dd59419220e93 /PKGBUILD
downloadaur-gomoku.tar.gz
1.0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7137e304cad7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=gomoku
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='A simple gomoku game'
+url="https://github.com/alexkdeveloper/gomoku"
+arch=('x86_64' 'aarch64')
+license=('GPL3')
+depends=('gtk3')
+makedepends=('git' 'meson' 'vala')
+checkdepends=('appstream-glib')
+source=("git+$url.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs || :
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ ln -s io.github.alexkdeveloper.$pkgname "$pkgdir/usr/bin/$pkgname"
+}