summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwenLiangcan2016-03-25 13:16:43 +0800
committerwenLiangcan2016-03-25 13:16:43 +0800
commit59a14e700a5d74460b009195ca0b74af3763fa6e (patch)
tree4a4ce048532306f72f8f347edb95d11374508f9c /PKGBUILD
parentadb7d3cb3190d96cde0baa1e2e08fcb621dafcef (diff)
downloadaur-gotags-git.tar.gz
gotags-git 1:1.3.0.18.gbe986a3-1.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0fdee2c261a7..113dcf139d38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=gotags-git
_pkgname=gotags
-pkgver=20150322
+pkgver=1.3.0.18.gbe986a3
+epoch=1
pkgrel=1
pkgdesc="ctags-compatible tag generator for Go."
-arch=("any")
+arch=('x86_64' 'i686')
url="https://github.com/jstemmer/gotags"
-license=('Other')
+license=('MIT')
makedepends=('git' 'go')
depends=()
provides=('gotags')
@@ -16,16 +17,17 @@ md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
- git log -1 --format='%cd' --date=short | tr -d -- '-'
+ git describe --tags --long | sed 's/^v//;s/-/./g'
}
build() {
- cd "${_pkgname}"
+ cd "${srcdir}/${_pkgname}"
GOPATH=${srcdir} go build -o "${_pkgname}"
}
package() {
- cd ${_pkgname}
+ cd "${srcdir}/${_pkgname}"
install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
}
+