summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2021-12-11 02:03:48 -0500
committerTony Lambiris2021-12-11 02:03:48 -0500
commit35702acfcb488584daa0f8c8c446cc6bef5a1ab7 (patch)
tree0a62896b2ef56ea903e4ea14d9ca88e0e8cf598d /PKGBUILD
parentccbbf90ab802bf735a32ca03b6083e0158079cf1 (diff)
downloadaur-goxel-git.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d0ceab2cb8b1..903565acbb76 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=goxel-git
pkgver=r126.0e00703
-pkgrel=2
+pkgrel=3
pkgdesc="Download accelerator written in Go (inspired by axel)"
url="https://github.com/m1ck43l/goxel"
arch=('x86_64' 'i686')
@@ -22,11 +22,6 @@ prepare() {
install -m755 -d "${srcdir}/go/src/github.com/m1ck43l/"
ln -sf "${srcdir}/${pkgname}" "${srcdir}/go/src/github.com/m1ck43l/goxel"
-
- cd "${srcdir}/go/src/github.com/m1ck43l/goxel"
-
- export GOPATH="${srcdir}/go"
- go get -v ./...
}
build() {
@@ -35,10 +30,8 @@ build() {
mkdir -p build
export GOPATH="${srcdir}/go"
- go build -ldflags "-s -w" \
- -gcflags="all=-trimpath=${GOPATH}/src" \
- -asmflags="all=-trimpath=${GOPATH}/src" \
- -o build/goxel .
+ go build -trimpath -modcacherw \
+ -ldflags "-s -w" -o build/goxel
}
package() {