summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorqwence2016-03-22 18:24:27 -0400
committerqwence2016-03-22 18:24:27 -0400
commit98709604334643c7f8f709bf458c56a08a291477 (patch)
tree1f6065b3513d95c5bf280da7f0ea88e1073b3463 /PKGBUILD
downloadaur-gpicker.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..133f7f18dba6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: qwence <queen.wenceslas@gmail.com>
+# Contributor: Limao Luo <luolimao+AUR@gmail.com>
+# Contributor: Ian Yang <me@iany.me>
+
+pkgname=gpicker
+pkgver=2.3
+pkgrel=1
+pkgdesc="A program that allows you to quickly and conveniently pick file in a (possibly very large) project"
+arch=(i686 x86_64)
+url=http://savannah.nongnu.org/projects/$pkgname
+license=(GPL3)
+depends=(gtk2)
+options=(!libtool)
+source=(http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.gz)
+sha256sums=('565b39aaca0e6d3b824eaa3f589200c6ac16abfb2377a82d923e3d47c43f9a4b')
+sha512sums=('5baa2db70db1af42febd32c5b008d9c003e9d2546befe780308e815a0f679a8dc984c0cd844adc69d1b9a5515609a372c640d02e8590e594032dbe72a955b8d2')
+
+build() {
+ cd $pkgname-$pkgver/
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ make -C $pkgname-$pkgver DESTDIR="$pkgdir" install
+}
+