summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2022-09-02 21:06:27 -0400
committerKevin MacMartin2022-09-02 21:06:27 -0400
commit1c35f4b0e93dae4845d80070a837fad47db2a7a2 (patch)
treef282fc8c0df0b85aee8deb43e1018c03549f3619 /PKGBUILD
parent5783a1e005ef7d2e64c791504e0a60ac9722155b (diff)
downloadaur-gps-share.tar.gz
Contain the build locally so we aren't polluting the user's home directory with cached rust stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe429cbdeb36..04daaec974a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=gps-share
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc='Utility to share your GPS device on local network'
url='https://github.com/zeenix/gps-share'
license=('GPL2')
@@ -14,6 +14,7 @@ source=("https://github.com/zeenix/gps-share/archive/refs/tags/${pkgver}.tar.gz"
sha512sums=('e2552b99169b7e914c225362db1b58cea0e7b0fb22340b1f6a7969f96a7fc497f921241a60166ed4712353de0808e99a859b7e270e9452963e5b86e913a1a949')
build() {
+ export CARGO_HOME="$srcdir"
cd $pkgname-$pkgver
cargo build --release
}