summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJohn Shuping2016-02-14 08:07:28 -0500
committerJohn Shuping2016-02-14 08:07:28 -0500
commitb0b04496892a426f01609bdae5577d828097dc24 (patch)
treeff93e391094f35021b31eb64ba88b1d0539a6908 /PKGBUILD
downloadaur-gr-ais-git.tar.gz
Initial addition of gr-ais package files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e6b1126eebdf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Michael Düll <mail@akurei.me> PGP-Key: 6D666EC8
+
+pkgname=gr-ais-git
+pkgrel=1
+pkgver=20160213
+pkgdesc="Automatic Information System decoder for shipborne position reporting for the Gnuradio project"
+
+arch=('i686' 'x86_64')
+url="https://github.com/bistromath/gr-ais"
+license=('GPL')
+depends=('gnuradio')
+makedepends=('git' 'cmake')
+provides=('gr-ais')
+
+_gitroot="https://github.com/bistromath/gr-ais.git"
+_gitname="gr-ais"
+
+pkgver() {
+ date +%Y%m%d
+}
+
+build() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [[ -d "$_gitname" ]]; then
+ cd "$_gitname" && git pull origin
+ msg "The local files are updated."
+ else
+ git clone "$_gitroot" "$_gitname"
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting build..."
+
+ rm -rf "$srcdir/$_gitname-build"
+ git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
+ cd "$srcdir/$_gitname-build/"
+
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ../
+ make
+}
+
+package() {
+ cd "$srcdir/$_gitname-build/build/"
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et: