summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan McCurry2017-04-23 21:51:54 -0400
committerDan McCurry2017-04-23 21:51:54 -0400
commitf76b27c4139cf07bbda5e2a53d5b2a473914fd74 (patch)
tree00a6d559be861737a3168eb25da16f3d70f9fa0a /PKGBUILD
parent11457661225a0378d3065058786a746ae943d180 (diff)
downloadaur-gr-osmosdr-nonfree-git.tar.gz
Needed to move some optdepends to depends to build packages that depend on this
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d95fc758238..0e7e15cd9db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Modified from gr-osmosdr-git PKGBUILD
pkgname=gr-osmosdr-nonfree-git
-pkgver=0.1.4.72.g164a09f
-pkgrel=2
+pkgver=0.1.4.91.gcf95494
+pkgrel=1
pkgdesc="GNU Radio source block for OsmoSDR with nonfree components, such as sdrplay, enabled."
arch=('i686' 'x86_64')
url="http://sdr.osmocom.org/trac/"
@@ -13,6 +13,10 @@ license=('custom')
depends=(
'gnuradio'
'swig'
+ 'rtl-sdr'
+ 'libuhd'
+ 'libmirisdr-git'
+ 'libosmosdr-git'
'airspy'
)
makedepends=(
@@ -23,9 +27,6 @@ makedepends=(
)
optdepends=(
'gnuradio-iqbal: Osmocom IQ imbalance correction support'
- 'rtl-sdr-git: Osmocom RTLSDR support'
- 'libosmosdr-git: sysmocom OsmoSDR support'
- 'libmirisdr-git: Osmocom MiriSDR support'
'soapysdr-git: SoapySDR support'
'libsdrplay: SDRplay RSP support'
'gnuradio-fcdproplus: FUNcube Dongle Pro+ support'