summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2024-03-30 20:59:27 +0000
committerJoão Figueiredo2024-03-30 20:59:27 +0000
commit2097008f5f3392c9e53b4977a286081ebf441e02 (patch)
tree3cf261fee97d9763be368d23a84205d02772a112 /PKGBUILD
parentcaf1e1db479073ef1d4001b8ccd432adde022368 (diff)
downloadaur-grantlee-git.tar.gz
Merged with official ABS grantlee PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 25 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c84aac2fe7b5..a483c76dc4e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,36 @@
+# Merged with official ABS grantlee PKGBUILD by João, 2024/03/30 (all respective contributors apply herein)
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
+
pkgname=grantlee-git
-pkgver=v5.2.0.0.gb6454a9
+pkgver=5.1.0_r1417.g90f0278
pkgrel=1
-pkgdesc="Grantlee is a string template engine based on the Django template system."
-arch=('i686' 'x86_64')
-url="http://www.grantlee.org"
-license=('LGPL2.1')
-depends=('qt5-base' 'qt5-script')
-makedepends=('git' 'cmake')
-optdepends=()
-conflicts=('grantlee' 'grantlee-qt5-git')
-provides=('grantlee' 'grantlee-qt5')
-replaces=('grantlee-qt5-git')
-source=("$pkgname"::'git+https://github.com/steveire/grantlee.git')
-md5sums=('SKIP')
+pkgdesc='A string template engine based on the Django template system and written in Qt'
+arch=($CARCH)
+url='https://github.com/steveire/grantlee'
+license=(LGPL2.1)
+depends=(qt6-declarative)
+makedepends=(git cmake doxygen graphviz)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- # Use the tag of the last commit
- local ver="$(git describe --tags --long)"
- printf "%s" "${ver//-/.}"
+ cd ${pkgname%-git}
+ _ver="$(git describe | sed 's/^v//;s/-.*//')"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
build() {
- mkdir "build"
- cd "build"
- cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr "../$pkgname"
- make
+ cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_TESTS=OFF
+ cmake --build build
+ cmake --build build --target docs
}
package() {
- cd "build"
- make DESTDIR="$pkgdir/" install
+ DESTDIR="$pkgdir" cmake --install build
+ install -Dm644 build/apidox/* -t "$pkgdir"/usr/share/doc/$pkgname
}