summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2021-04-18 12:08:17 +0200
committerhaawda2021-04-18 12:08:17 +0200
commit8882b2ac1a1943561792358589d6f7d3a560ff6d (patch)
tree6cd6f4037f48bd067fd8aa542b19628b380062cc /PKGBUILD
parentdce8196b36fd47732aee282dee492afbe9497c53 (diff)
downloadaur-gri-git.tar.gz
repome patch, add pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c4ef20e7740..542b5a2baa6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: big_gie nbigaouette . at . gmail.com
pkgname=gri-git
-pkgver=2.12.26
+pkgver=2.12.23.r20.gd9969d1
pkgrel=1
pkgdesc="A script-based language for scientific graphics programming"
arch=('i686' 'x86_64')
@@ -13,16 +13,14 @@ depends=('perl')
conflicts=('gri')
provides=('gri')
makedepends=('git' 'ghostscript' 'imagemagick' 'texlive-core' 'perl-perl4-corelibs')
-source=("git+https://github.com/dankelley/gri.git" inputencoding.patch)
-sha256sums=('SKIP'
- 'b16d82db8958336fe0839c2aef30fd6fb8c75ea217c30e9ce64e06697b867abd')
-options=('!makeflags')
+source=("git+https://github.com/dankelley/gri.git")
+sha256sums=('SKIP')
-prepare() {
+pkgver() {
cd ${pkgname%-git}
- git apply "$srcdir"/inputencoding.patch
+ git describe --tags | sed 's+-+.r+' | tr - . | cut -c2-
}
-
+
build() {
cd ${pkgname%-git}
aclocal