summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2020-06-21 13:44:43 +0000
committerBalló György2020-06-21 13:44:43 +0000
commit821836bdbd12d54522e662452684f0a88dcff2be (patch)
tree082c2c6389cfdc4e49988cb0cd48b855f1d30cc1 /PKGBUILD
downloadaur-gsvg.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3d501ace6d23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+
+pkgname=gsvg
+pkgver=0.5.3+140+gcbbb996
+pkgrel=1
+pkgdesc="GObject API for SVG"
+arch=(x86_64)
+url="https://gitlab.com/pwmc/gsvg"
+license=(LGPL2.1)
+depends=(gxml graphene)
+makedepends=(git meson vala)
+_commit=cbbb9967bd86fc5e602e407859239bf2dff4abad # master~13
+source=("git+https://gitlab.com/pwmc/gsvg#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}