summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarsten Teibes2021-04-18 19:43:39 +0200
committerCarsten Teibes2021-04-18 19:43:39 +0200
commitaccf7d3791457bd6f241f11315031038e647cd95 (patch)
treee3c495aa45309a5bf073303ab8f2c1834bc9167b /PKGBUILD
downloadaur-gtkhash-peony-git.tar.gz
[new] gtkhash-peony-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a03e7a799d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: carstene1ns - https://git.io/ctPKG
+
+pkgname=gtkhash-peony-git
+pkgver=v1.4.r64.g3afea16
+pkgrel=1
+pkgdesc='A Peony filemanager plugin for computing message digests or checksums (development version).'
+arch=('i686' 'x86_64')
+url='https://github.com/tristanheaven/gtkhash'
+license=('GPL2')
+makedepends=('git')
+depends=('gtkhash-git' 'peony')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=(gtkhash::"git+https://github.com/tristanheaven/gtkhash.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd gtkhash
+
+ git describe --long --tags | sed 's/-/.r/;s/-/./'
+}
+
+build() {
+ cd gtkhash
+
+ ./autogen.sh
+ ./configure --prefix=/usr --disable-schemas-compile --disable-gtkhash \
+ --enable-linux-crypto --enable-nettle --enable-peony
+ make
+}
+
+package() {
+ make -C gtkhash/src/nautilus DESTDIR="$pkgdir/" install
+}