summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael DeGuzis2018-06-21 13:48:22 -0400
committerMichael DeGuzis2018-06-21 13:48:22 -0400
commitc1dfb99e7d74b24d48fb8319cac1cc3bbfe6c7dd (patch)
tree6baf1220d7f6ba7937207ecbeae00642e6707566 /PKGBUILD
parentc3787afd4d2eaca6c6c1aeeca87a4e216d56e794 (diff)
downloadaur-guacamole-server-git.tar.gz
rebase with main pkg
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac0252b374c4..14bd38d70a21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=guacamole-server-git
_gitname=guacamole-server
-pkgver=0.9.13.incubating.r42.g6236eb8f
+pkgver=0.9.14.r169.gc120aa02
pkgrel=1
pkgdesc="Guacamole proxy daemon"
arch=('i686' 'x86_64')
@@ -23,10 +23,13 @@ optdepends=('libssh: for ssh protocol support'
source=(
"$_gitname::git+https://github.com/apache/incubator-guacamole-server.git"
'guacd.service'
+ 'libavcodec.patch'
)
md5sums=('SKIP'
- 'dfaa29349d2e73af6dac75d6cafbd762')
+ 'dfaa29349d2e73af6dac75d6cafbd762'
+ '6cf58f3148d0ea3f24b4fa362ca79807'
+ )
pkgver() {
cd "$srcdir"/$_gitname
@@ -34,17 +37,18 @@ pkgver() {
}
build() {
+ ## Wno-error=format-overflow added to workaround build in GCC 7.1.1
cd "$srcdir"/$_gitname
+ patch -Np1 -i ../libavcodec.patch
autoreconf -fi
- PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
- CFLAGS+=" -I/usr/include/openssl-1.0" \
- LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl" \
+ #PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig \
+ #CFLAGS+=" -I/usr/include/openssl-1.0" \
+ #LDFLAGS+=" -L/usr/lib/openssl-1.0 -lssl" \
./configure \
- --with-openssl \
--prefix=/usr \
- --sbindir=/usr/bin \
+ --sbindir=/usr/bin \
CPPFLAGS="-Wno-error=pedantic -Wno-error=format-overflow"
- make
+ make
}
package() {