summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaco Pascal2023-03-16 03:40:23 -0400
committerPaco Pascal2023-03-16 03:40:23 -0400
commit2f697a21326919b30c0faa04bb957ce97370ad56 (patch)
tree4922d3f44b65a9a1c51975356c2e28f47f9bded4 /PKGBUILD
parent3c72f586e81bb49baf8901e32ae8c72a712441f9 (diff)
downloadaur-guile-bytestructures-git.tar.gz
Implemented suggestions by made FabioLolix
These suggestions are: - Use a pkgver() function. - Packages that are part of base-devel shouldn't be in makedepends (automake, autoconf,pkgconf). - 'git' is missing from makedepends. - Build the package in a clean chroot. Reference: https://aur.archlinux.org/packages/guile-zlib-git#comment-905700
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 00b991e1858c..eeaf91655059 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,20 +5,26 @@
_checkoutdir='scheme-bytestructures'
_pkgname='guile-bytestructures'
pkgname="${_pkgname}-git"
-pkgver=latest
+pkgver=r306.a6d5d25
pkgrel=1
pkgdesc='Structured access library to bytevector contents for Guile.'
-arch=('any')
+arch=('x86_64')
url='https://github.com/TaylanUB/scheme-bytestructures'
license=('GPL3')
options=('!strip')
depends=('guile')
-makedepends=('autoconf' 'automake')
+makedepends=('git')
conflicts=("${pkgname%-git}")
provides=("${pkgname%-git}")
source=('git+https://github.com/TaylanUB/scheme-bytestructures.git')
md5sums=('SKIP')
+pkgver() {
+ # Number of revisions since beginning of the history.
+ cd "${_checkoutdir}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
prepare() {
cd "${_checkoutdir}"
aclocal