summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoralexcoder042023-04-29 13:08:29 +0200
committeralexcoder042023-04-29 13:08:29 +0200
commit37beb47297fcd158be36c92610cb2ed57fa2abd4 (patch)
treead7e8400ab71446d0f59dac0e9bba220f34be8b1 /PKGBUILD
downloadaur-gupload.tar.gz
v0.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54a747f44bef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: alexcoder04 <alexcoder04@protonmail.com>
+pkgname=gupload
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="simple HTTP server to transfer files between machines on the local network "
+arch=('x86_64')
+url="https://github.com/alexcoder04/gupload"
+license=('AGPL3')
+groups=()
+depends=()
+makedepends=(go)
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$url/archive/refs/tags/v$pkgver.tar.gz")
+noextract=()
+md5sums=('7449ffd6e3b9dcc246b17a02a524dcc6')
+
+build(){
+ cd "$pkgname-$pkgver"
+
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ export GOOS="linux"
+ export GOARCH="amd64"
+
+ go build -o "$pkgname" .
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "README.md" "$pkgdir/usr/share/doc/$pkgname/README.md"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+