summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Haag2024-02-26 13:26:54 +0100
committerChristoph Haag2024-02-26 13:26:54 +0100
commit9417a6f83fad5b3de2ab02874b36b52bd5aa0774 (patch)
tree6dda83723bd26a4591dfca7e031434ff2ab34011 /PKGBUILD
parent33158b00c88af4091b66dde5c5d967568ae2c8c3 (diff)
downloadaur-gxr-git.tar.gz
clean up namcap warnings
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83c839f46c78..63a306780494 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,18 @@
_realname='gxr'
pkgname="$_realname-git"
-pkgver=0.16.0.1148.b204356
+pkgver=0.16.0.r1163.426226e
pkgrel=1
pkgdesc='A glib wrapper for the OpenVR and OpenXR APIs.'
arch=('i686' 'x86_64')
url='https://gitlab.freedesktop.org/xrdesktop/gxr'
-depends=('gtk3' 'gulkan-git' 'openxr')
+depends=('glib2' 'glibc' 'graphene' 'gtk3' 'gulkan-git' 'json-glib' 'openxr' 'vulkan-icd-loader')
provides=("$_realname="$pkgver)
conflicts=("$_realname")
makedepends=('meson' 'git' 'vulkan-headers' 'gtk-doc')
license=('MIT')
-
source=('git+https://gitlab.freedesktop.org/xrdesktop/gxr.git#branch=main')
-
optdepends=('monado-git: The open source OpenXR runtime.')
-
md5sums=('SKIP')
ver() {
@@ -25,15 +22,13 @@ ver() {
}
pkgver() {
- cd $_realname
- hash=$(git log --pretty=format:'%h' -n 1)
- revision=$(git rev-list --count HEAD)
- echo $(ver).$revision.$hash
+ cd "$_realname"
+ printf "$(ver).r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
}
build() {
rm -rf build
- arch-meson $_realname build --libdir=lib --buildtype release -Dapi_doc=true
+ arch-meson "$_realname" build --libdir=lib --buildtype release -Dapi_doc=true
ninja -C build
}