summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorØystein Sture2025-05-18 21:15:16 +0200
committerØystein Sture2025-05-18 21:15:16 +0200
commit1d056cb274f73ee87049476844a66161746eca89 (patch)
tree1cf978437adc010e0d3b7fc0314d8c29fef24fd7 /PKGBUILD
parent383d0d01eaaeabe54e7fd7a03aee4240b9c49074 (diff)
downloadaur-gz-launch7.tar.gz
Patch PR #295#
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c2b7e9e2ae90..8aadc4db5c23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gz-launch7
pkgver=7.1.1
-pkgrel=2
+pkgrel=3
_pkgmaj=${pkgver%%.*}
_pkgbase=${pkgname::-${#_pkgmaj}}
pkgdesc="Run and manage programs and plugins."
@@ -32,8 +32,15 @@ optdepends=(
'libwebsockets: a websocket server for simulation'
)
provides=("${_pkgbase}=${_pkgmaj}")
-source=("https://github.com/gazebosim/${_pkgbase}/archive/${pkgname}_${pkgver}.tar.gz")
-sha256sums=('dba949260bf399514aaaff12e98806edeb18f89e11643e12b221caa06a7dc1e0')
+source=("https://github.com/gazebosim/${_pkgbase}/archive/${pkgname}_${pkgver}.tar.gz"
+ "https://github.com/gazebosim/${_pkgbase}/pull/295.patch")
+sha256sums=('dba949260bf399514aaaff12e98806edeb18f89e11643e12b221caa06a7dc1e0'
+ '37069d666f130bc75339bb3568ae9668debac3997bd6857773087b888f049d7a')
+
+prepare() {
+ cd "${_pkgbase}-${pkgname}_${pkgver}"
+ patch -p1 < ${srcdir}/295.patch
+}
build() {
cmake -B build -S "${_pkgbase}-${pkgname}_${pkgver}" \