summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2016-01-07 00:25:24 +0100
committeranthraxx2016-01-07 00:26:53 +0100
commit7be46ce39f77364589d488dec94e9106029c2726 (patch)
treeceb0417e7eae45cb394f24e4b24825dc28e9237d /PKGBUILD
parent358d44e32dcc66cd61f3236e8277d2f38772d0fc (diff)
downloadaur-haka.tar.gz
upgpkg: haka 0.3.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b92e58dc6be..91937ab4fe98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=haka
pkgver=0.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="Collection of tools that allows capturing TCP/IP packets and filtering them based on Lua policy files"
url="http://haka-security.org/"
arch=('i686' 'x86_64')
@@ -12,20 +12,25 @@ makedepends=('cmake' 'swig' 'doxygen' 'python2-sphinx' 'check' 'iniparser')
options=('!emptydirs')
backup=('etc/haka/haka.conf')
source=(${pkgname}-${pkgver}.tar.gz::https://github.com/haka-security/haka/releases/download/v${pkgver}/haka_${pkgver}_source.tar.gz
- fix-32bit-build.patch)
+ fix-32bit-build.patch::https://github.com/haka-security/haka/commit/187e56b8df5b2ddfd8ade5eef747b3952ee6435c.patch
+ missing-return.patch::https://github.com/haka-security/haka/commit/185b0aee04d8d80997a6d250c5788ba058149981.patch
+ unused-arg.patch::https://github.com/haka-security/haka/commit/50c5968b345f7c76ede00cb2103d47aa32d6648c.patch)
sha512sums=('8c2c219b8e89710289e300c1fd8ad9b6a95562efc77966bee7ddf343d73b108d6ebf3f7ff73963ca66954bdc0719c08eef127e58ffa42469ae47cf95e817e720'
- 'd4b5db5fb3d04a4c2bb6d4c5833d34a21b3aac8f81eafa8305a0ca57a8bd24578a7baab05e485cb855d3ff0c48b3baa1627ed1db3553fda8c4b7de420d61a857')
+ 'b3be609b41e46de2d611bd08887b032fa0fba8d00256c306f449489ea951a4343ec8bba7588cb80f89e35f82c9892fe6581e9fab25c5e25715822909f45e6d9c'
+ '3ae11ec71f9f66fe3f5d28a3ab10cb772b674a89d87939fbd3e733d60dee298173e7248a1c42ee48638d11e9a3aa730f105d942d2c553143f13aba1c11147a5a'
+ '16a7f23b106a0c6af18f8d3fdc7f6c4cb074af7aae1665db9b74ee8231f8962a6a61f81d2a9aabbe8ed8acb514fc9ae8aa7c125d219c3fed3ffc5c4c19b42ee8')
prepare() {
cd ${pkgname}_${pkgver}_source
patch -p1 < "${srcdir}/fix-32bit-build.patch"
+ patch -p1 < "${srcdir}/missing-return.patch"
+ patch -p1 < "${srcdir}/unused-arg.patch"
sed 's|sbin|bin|g' -i \
CMakeLists.txt \
src/hakactl/CMakeLists.txt \
src/haka/CMakeLists.txt \
external/luajit/luajit.cmake
- sed 's|-Wall -Werror|-Wall|g' -i CMakeLists.txt
sed 's|sphinx-build|sphinx-build2|g' -i build/FindSphinx.cmake
# temporary html docs via doxygen as sphinx generator is broken
sed -r 's|(GENERATE_XML[ ]+=) YES|\1 NO|g' -i doc/Doxyfile.in