summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormatclab2020-03-12 11:35:53 +0100
committermatclab2020-03-12 11:35:53 +0100
commit8dc2ec01119f30e76aac72f2bee23e5b4860f7ad (patch)
tree6c4543190a63ea476644ea48f61514106c2fed30 /PKGBUILD
parentdcf6648559515ccad9892ede547419eab85960ca (diff)
downloadaur-hamster-time-tracker2.tar.gz
v3.0.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 444f8c79ee20..20c749731f91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,18 @@
# Contributor: Georg Vogetseder <georg.vogetseder@gmail.com>
pkgname=hamster-time-tracker2
-pkgver=2.2.2
-pkgrel=4
+pkgver=3.0.1
+pkgrel=0
pkgdesc="Time tracking application that helps you to keep track on how much time you have spent during the day on activities you choose to track"
arch=('any')
url="https://github.com/projecthamster/hamster"
license=('GPL')
depends=('python-dbus' 'python-cairo' 'python-gobject' 'python-xdg' 'desktop-file-utils')
makedepends=('intltool' 'gnome-doc-utils')
-source=("https://github.com/projecthamster/hamster/archive/v$pkgver.tar.gz"
-"mcl.patch")
+source=("https://github.com/projecthamster/hamster/archive/v$pkgver.tar.gz")
prepare() {
cd hamster-$pkgver
- #patch -p1 < ../mcl.patch
-
}
build() {
@@ -31,12 +28,7 @@ package() {
cd hamster-$pkgver
./waf install --destdir=$pkgdir
install -dm755 "$pkgdir/usr/lib/python3.8/site-packages"
- mv $pkgdir/usr/lib/python2.7/site-packages/hamster $pkgdir/usr/lib/python3.8/site-packages
- # Move bash completion and GConf schema to its correct place
- install -dm755 "$pkgdir/usr/share/bash-completion/completions"
- mv "$pkgdir/etc/bash_completion.d/hamster.bash" "$pkgdir/usr/share/bash-completion/completions/hamster"
- mv "$pkgdir/etc/gconf" "$pkgdir/usr/share"
- rm -r "$pkgdir/etc"
+ # gschemas.compiled should not be part of the package, it is generated by the glib-compile-schemas Pacman hook
+ rm -f "${pkgdir}/usr/share/glib-2.0/schemas/gschemas.compiled"
}
-md5sums=('980ddf4ceef842da255bda37914f971d'
- '37e26052a8cc05eefa74dec1ca42e961')
+md5sums=('fc408882ca5253fc81da81e3790e1375')