summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVincent Grande2020-12-22 23:46:28 -0500
committerVincent Grande2020-12-22 23:46:28 -0500
commitaa5e172a823b261775666c3c3438ecd2aaec19fb (patch)
tree0bae21eba7d1efafd404e583cac07a36f236830a /PKGBUILD
downloadaur-harfbuzz-minimal-git.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c8f6532604a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Vincent Grande (shoober420) <shoober420@gmail.com>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+
+pkgname=(harfbuzz-minimal-git)
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="OpenType text shaping engine"
+url="https://www.freedesktop.org/wiki/Software/HarfBuzz"
+arch=(x86_64)
+license=(MIT)
+makedepends=(glib2 freetype2 graphite harfbuzz cairo icu gobject-introspection
+ ragel git python meson)
+#checkdepends=(python-fonttools python-setuptools)
+source=("git+https://github.com/harfbuzz/harfbuzz")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd harfbuzz
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ cd harfbuzz
+}
+
+build() {
+ arch-meson harfbuzz build \
+ -D graphite=enabled \
+ -D docs=disabled \
+ -D icu=disabled
+ meson compile -C build
+}
+
+#check() {
+# mkdir -p tmp
+# TMPDIR="$PWD/tmp" meson test -C build --print-errorlogs
+# rm -r tmp
+#}
+
+package_harfbuzz-minimal-git() {
+ provides=(harfbuzz libharfbuzz.so libharfbuzz-subset.so libharfbuzz-gobject.so)
+ conflicts=(harfbuzz)
+ optdepends=('cairo: hb-view program')
+
+ DESTDIR="$pkgdir" meson install -C build
+
+ install -Dt "$pkgdir/usr/share/licenses/$pkgname" -m644 harfbuzz/COPYING
+}