summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordeltaclock2022-12-19 01:41:13 +0200
committerdeltaclock2022-12-19 01:41:13 +0200
commitc43203f8cad9267d9ecff50296b405fda5ea35a8 (patch)
treed9ba1516e635b1d917175dee44bd1c194aaf7e5b /PKGBUILD
parentb09a57602a8086dfdfc8d40c92749233fb0d571a (diff)
downloadaur-hashclash-cuda-git.tar.gz
Fix build process by removing C and CXX flags
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ada6eb6a760..48b18f67a2ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,6 @@
-# Maintainer: Bert Peters <bert@bertptrs.nl>
pkgname=hashclash-cuda-git
pkgver=r104.2969e0c
-pkgrel=1
+pkgrel=2
pkgdesc="Project HashClash - MD5 & SHA-1 cryptanalysis with CUDA support"
arch=(x86_64)
url="https://github.com/cr-marcstevens/hashclash"
@@ -21,16 +20,18 @@ pkgver() {
}
build() {
+ # the default env variables were causing problems, let configure detect them
+ unset CXXFLAGS CFLAGS
cd "$srcdir/${pkgname%-cuda-git}"
autoreconf --install
./configure --prefix=/usr --with-cuda=/opt/cuda
- make
+ make -j4
}
package() {
cd "$srcdir/${pkgname%-cuda-git}"
make DESTDIR="$pkgdir/" install
- install -D "$srcdir/${pkgname%-git}/LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -d "$pkgdir/usr/share/${pkgname%-git}/scripts"
install -Dt "$pkgdir/usr/share/${pkgname%-git}/scripts" -m755 scripts/*
}