summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDrRac272018-08-06 22:51:39 +0200
committerDrRac272018-08-06 22:51:39 +0200
commitd5d1cde0bbe17c827ee0b687519d0605258a0f2d (patch)
treee48f7c77abd924fbaeda90e5464a2a397c03c4f4 /PKGBUILD
parent3f86be17c30775958ddeb62a25732a9cd3da72a4 (diff)
downloadaur-hashid.tar.gz
initial commit for new hashid
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 14 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50349d1b53d0..bd776522b425 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,22 @@
-# Maintainer: Ari Mizrahi <codemunchies at debugsecurity dot com>
-# Contributor: ArchAssault Project <https://www.archassault.org>
+# Maintainer: DrRac27 <drrac27 at riseup dot net>
pkgname=hashid
-pkgver=1.1
-pkgrel=3
-pkgdesc="Software to identify the different types of hashes used to encrypt data and especially passwords"
-arch=('any')
-url=('http://code.google.com/p/hash-identifier')
-license=('GPL3')
-makedepends=('subversion' 'dos2unix')
-depends=('python2')
-source=('svn+http://hash-identifier.googlecode.com/svn/trunk/')
-md5sums=('SKIP')
+pkgver=v3.1.4+16+7e8473
+pkgrel=1
+_githash=7e8473a823060e56d4b6090a98591e252bd9505e
+pkgdesc="Identify the different types of hashes used to encrypt data and especially passwords"
+arch=("any")
+url="https://github.com/psypanda/hashID"
+license=("GPL3")
+depends=("python>=3.3")
+source=("https://raw.githubusercontent.com/psypanda/hashID/${_githash}/hashid.py" "https://raw.githubusercontent.com/psypanda/hashID/${_githash}/doc/man/hashid.7")
+sha512sums=("1c7c1834e9a8ae45daa4266ef44697bd09ffe85edc8e77694513dbc6e9640e2195b9ca8433d3e73f3a6fdbb96158d58dfd6f0e1a109c19c38017a57874abb6ab" "f8dee5ac2db86eb0ef0b142602183fd4f60b2cd68ac062563be21b090f52fc36a193d98df6d34fac6d51a141cc60d9d1b5406ce6a06f6e1864693a018aa7d2b7")
prepare() {
- cd "$srcdir/trunk/Hash_ID_v$pkgver"
-
- # Fix line endings.
- dos2unix Hash_ID.py
-
- # Fix shebang header.
- sed -i 's/env python$/env python2/' Hash_ID.py
+ gzip --force hashid.7
}
package() {
- cd "$srcdir/trunk/Hash_ID_v$pkgver"
-
- install -Dm755 Hash_ID.py "$pkgdir/usr/bin/hashid"
+ install -Dm 755 hashid.py "${pkgdir}/usr/bin/hashid"
+ install -g 0 -o 0 -Dm 0644 hashid.7.gz "${pkgdir}/usr/share/man/man7/hashid.7.gz"
}