summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorberberman2020-06-27 20:34:02 +0800
committerberberman2020-06-27 20:34:02 +0800
commit1f5bfb531d386bba58248eb3c0e4f32096ff4ccd (patch)
treee792c37ea04885628071af83aec1a6a8100b720b /PKGBUILD
parent5432d8988d860e278faf7757a1032b8ee7a7d167 (diff)
downloadaur-haskell-fixed.tar.gz
Update to 0.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 27 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8acb25160245..340b9dc8114e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,42 @@
-# $Id$
-# Maintainer: Emanuel Couto <unit73e at gmail dot com>
+# Maintainer: berberman <hatsue@typed.icu>
+# Contributor: Emanuel Couto <unit73e at gmail dot com>
# Contributor: Carlos E. Garcia <carlos at cgarcia dot org>
_hkgname=fixed
pkgname=haskell-fixed
-pkgver=0.2.1.1
-pkgrel=2
+pkgver=0.3
+pkgrel=1
pkgdesc="Signed 15.16 precision fixed point arithmetic"
url="http://github.com/ekmett/fixed"
license=('custom:BSD3')
-arch=('i686' 'x86_64')
+arch=('x86_64')
depends=('ghc-libs')
makedepends=('ghc')
-source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
-sha512sums=('99f0410deffbecaf4ffb15543e3fd060cc679b238644490cbb0a608dda9957fc4c0020bce667f6ca25fc02c52fced7e9ca40dabe899ec8649b522fdec75eb9c0')
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
+sha256sums=('9218ebd3af3f07335db8dcd148b3ce40acf984734c244cce5959f57402d48282')
build() {
- cd "${srcdir}/${_hkgname}-${pkgver}"
+ cd $_hkgname-$pkgver
- runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
- --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
- --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
- runhaskell Setup build
- runhaskell Setup register --gen-script
- runhaskell Setup unregister --gen-script
- sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
- sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+ runhaskell Setup configure -O --enable-shared --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
+
package() {
- cd "${srcdir}/${_hkgname}-${pkgver}"
-
- install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
- install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
- runhaskell Setup copy --destdir="${pkgdir}"
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
}