summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSolomon Choina2019-08-08 00:23:16 -0400
committerSolomon Choina2019-08-08 00:23:16 -0400
commit60a5d98afabff425525ff9c11498513e09be908b (patch)
tree1d6218cf53c145a58c035e8c3962c382da51add4 /PKGBUILD
downloadaur-haskell-gi-gsk.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea03679374c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+
+# Maintainer: Solomon Choina <shlomochoina@gmail.com>
+pkgname=haskell-gi-gsk
+_hkgname=gi-gsk
+pkgver=4.0.1
+pkgrel=1
+pkgdesc="Bindings for gsk, autogenerated by haskell-gi."
+url=https://hackage.haskell.org/package/gi-gsk
+license=('LGPL-2.1')
+arch=('i686' 'x86_64')
+depends=('ghc-libs' 'haskell-bytestring'
+'haskell-containers' 'haskell-gi-gdk' 'haskell-gi-cairo'
+'haskell-gi-glib' 'haskell-gi-gobject' 'haskell-gi-pango'
+'haskell-gi' 'haskell-gi-base' 'haskell-gi-overloading' 'haskell-text' 'haskell-transformers' 'haskell-gi-graphene')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('dd0ef5761336df9010ffd8b38c0ed26240e59a55c2fdfc07e8a399e7a26f8518')
+
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" --datasubdir="$pkgname" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}