summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSibren Vasse2015-08-12 13:50:15 +0200
committerSibren Vasse2015-08-12 13:50:15 +0200
commitfc3114fb629083a86d8c89495448e31cf0286c77 (patch)
treef050bbfc5f6f3459d91cd5ec40ad768dabaf7a64 /PKGBUILD
downloadaur-hfpforlinux-svn.tar.gz
Initial import to aur4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a9cecdf6cc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Sibren Vasse <arch at sibrenvasse dot nl>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+
+pkgname=hfpforlinux-svn
+pkgver=88
+pkgrel=8
+pkgdesc="HFP for Linux is a Bluetooth Hands-Free Profile server"
+url="http://nohands.sourceforge.net/"
+arch=('i686' 'x86_64')
+license=("GPL2")
+depends=('bluez-libs')
+optdepends=('libtool' 'libsalsa' 'audiofile' 'dbus' 'qt3')
+makedepends=('svn' 'speex')
+source=('hfpforlinux::svn+https://nohands.svn.sourceforge.net/svnroot/nohands/trunk')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$SRCDEST/hfpforlinux"
+ svnversion | tr -d [A-z]
+}
+
+build () {
+ cd $srcdir/hfpforlinux
+ ./autogen.sh
+ ./configure
+ sed -i '/^CXXFLAGS/s/$/ -fpermissive/' libhfp/Makefile
+ sed -i 's/-laudiofile -lspeexdsp/-laudiofile -lspeexdsp -lpthread/' test/Makefile
+ sed -i 's/-laudiofile -lspeexdsp/-laudiofile -lspeexdsp -lpthread/' include/Makefile
+ sed -i 's/-laudiofile -lspeexdsp/-laudiofile -lspeexdsp -lpthread/' qt/Makefile
+ sed -i 's/-laudiofile -lspeexdsp/-laudiofile -lspeexdsp -lpthread/' hfpd/Makefile
+ sed -i 's/-Wshadow -fno-exceptions/-Wshadow -fno-exceptions -fpermissive/' hfpd/Makefile
+ sed -i 's/CXXFLAGS = -march=x86-64/CXXFLAGS = -fstrict-aliasing -fpermissive -march=x86-64/' qt/Makefile
+ sed -i '810s/RegisterDirect/this->RegisterDirect/' include/libhfp/events.h
+ sed -i '859s/Invoke/BaseT::Invoke/' include/libhfp/events.h
+ sed -i 's/^LDFLAGS =/LDFLAGS = -lpthread/' hfpd/Makefile
+ sed -i 's/^libhfp_LIBS =/libhfp_LIBS = -lpthread/' test/Makefile
+ sed -i '1s/python/python2/' data/hfconsole.in
+ make
+}
+package() {
+ cd $srcdir/hfpforlinux
+ make DESTDIR="$pkgdir" install
+}