summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJesse Jaara2018-08-15 13:23:02 +0300
committerJesse Jaara2018-08-15 13:23:02 +0300
commit84b34f4bca9bbb55c24cbae6cf675fdd32842180 (patch)
treede2fa2493f7b755074c88744a4bc4071a54686a5 /PKGBUILD
parent4f900ed1ef9a3d55f99fb13ccaaa74426c5a71b0 (diff)
downloadaur-hfstospell.tar.gz
Update to v0.5.0 and fix building.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ee3f4c63ee73..9693af30a4b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Janne Haapsaari <iki.fi: haaja>
pkgname=hfstospell
-pkgver=0.4.5
+pkgver=0.5.0
pkgrel=1
pkgdesc='Helsinki Finite-State Transducer Technology (HFST) tools'
arch=('i686' 'x86_64')
@@ -11,13 +11,20 @@ license=('APACHE')
depends=('libxml++2.6' 'libarchive')
options=(!libtool)
source=(https://github.com/hfst/hfst-ospell/archive/v${pkgver}.tar.gz)
-md5sums=('efeaa3808274bacb509292e3398c3eec')
+md5sums=('3bd03999cd4ec1365768c76713e0d0ef')
-build() {
+prepare() {
cd "${srcdir}/hfst-ospell-${pkgver}"
+ sed 's|UnicodeString|icu::UnicodeString|g' -i office.cc
./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/hfst-ospell-${pkgver}"
+
./configure --prefix=/usr
+
make
}