summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTmplt2017-04-22 22:03:24 +0200
committerTmplt2017-04-22 22:03:24 +0200
commit7ef1f908be0f72d3cdbfda0fc7f930793a912d12 (patch)
treefaf09f77d1d2e0894c772a100f11834f882838f0 /PKGBUILD
downloadaur-hhpc-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..012218d80975
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Tmplt <tmplt@dragons.rocks>
+_pkgname=hhpc
+pkgname=hhpc-git
+pkgver=v0.3.1.r5.g44e8473
+pkgrel=1
+pkgdesc="A small utility to hide the mouse pointer with X.org (X11)"
+arch=("i686" "x86_64")
+url="https://github.com/aktau/${_pkgname}"
+license=("BSD")
+makedepends=("git" "pkg-config")
+depends=("libx11")
+conflicts=("hhpc")
+source=("${_pkgname}::git+${url}.git")
+md5sums=("SKIP")
+
+pkgver() {
+ git -C "${_pkgname}" describe --long --tags | sed "s/-/.r/;s/-/./g"
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}