summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Harting2024-03-23 18:20:15 +0100
committerGiovanni Harting2024-03-23 18:20:15 +0100
commit9191b345c1291b9623729b34025a41c653285c72 (patch)
tree069c067f5b1e89c690e22f695fa4d608197a8f8f /PKGBUILD
parentde7ab4ae8fa3ee1d7441d4f09726d84b479ac453 (diff)
downloadaur-hide-client.tar.gz
upgpkg: hide-client 0.9.9-1
upstream release formatting
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ea7b5f60bb4..cda24dd45089 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
# Contributor: Leonard Janis Robert König <ljrk at ljrk dot org>
pkgname=hide-client
-_pkgname=hide.client.linux
+_name=hide.client.linux
pkgver=0.9.9
pkgrel=1
-pkgdesc="Hide.me CLI VPN client for Linux"
-arch=(x86_64 aarch64 armv7h armv6h)
-url="https://github.com/eventure/hide.client.linux"
-license=(GPL2)
+pkgdesc='Hide.me CLI VPN client for Linux'
+arch=(x86_64 aarch64 armv7h)
+url='https://github.com/eventure/hide.client.linux'
+license=(GPL-2.0-only)
depends=(glibc)
makedepends=(go)
backup=('etc/hide.me/config')
-source=("https://github.com/eventure/$_pkgname/archive/$pkgver.zip")
+source=("$pkgname-$pkgver.zip::$url/archive/$pkgver.zip")
b2sums=('ca30b3442d9cee438c69719725f33d6702e82c252d5ee2130e984bc57f221edfa2dc943b07c6564f347cb4c618d0d5b0ab98851da31f8da0fe37e803f837c84b')
prepare() {
- cd "$_pkgname-$pkgver"
+ cd $_name-$pkgver
sed -e "s|CA.pem|/usr/share/hide.me/CA.pem|" \
-e "s|accessToken.txt|/etc/hide.me/accessToken.txt|" \
@@ -30,7 +30,7 @@ prepare() {
}
build() {
- cd "$_pkgname-$pkgver"
+ cd $_name-$pkgver
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
@@ -48,12 +48,12 @@ build() {
}
package() {
- cd "$_pkgname-$pkgver"
+ cd $_name-$pkgver
install -Dm755 -t "$pkgdir"/usr/bin hide.me
install -Dm644 -t "$pkgdir"/usr/share/hide.me CA.pem
- # For (system-wide) accessToken.txt
+ # for (system-wide) accessToken.txt
install -dm755 "$pkgdir"/etc/hide.me
install -Dm644 -t "$pkgdir"/etc/hide.me config
install -Dm644 -t "$pkgdir"/usr/lib/systemd/system hide.me@.service