summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTryton Van Meer2020-03-20 18:13:36 -0400
committerTryton Van Meer2020-03-20 18:16:27 -0400
commit4731a2366a5b258a97215bd0a46f38177da87d04 (patch)
treecc8225a1ffdffa35b3e1d34827b91c4b7408c591 /PKGBUILD
downloadaur-hiritsu.tar.gz
Initial commmit for hiritsu PKGBUILD.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8996c390ecb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Tryton Van Meer <trytonvanmeer at protonmail dot com>
+
+pkgname='hiritsu'
+_reponame='Hiritsu'
+pkgdesc='CLI tool for getting aspect ratio of files.'
+pkgver='1.0.0'
+pkgrel='1'
+arch=('x86_64')
+url='https://github.com/tryton-vanmeer/Hiritsu'
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('rust' 'gcc')
+checkdepends=('rust' 'git')
+provides=(hiritsu)
+source=("$pkgname-$pkgver.tar.gz::https://github.com/tryton-vanmeer/Hiritsu/archive/v${pkgver}.tar.gz")
+sha256sums=('786308efb66d1dc885aa9e7979fd51b955c16c1ae9956bd69a29095fc53ea6a9')
+
+build() {
+ cd "$_reponame-$pkgver"
+ cargo build --release --locked
+}
+
+check() {
+ cd "$_reponame-$pkgver"
+ cargo test --locked
+}
+
+package() {
+ cd "$_reponame-$pkgver"
+ install -Dm755 "target/release/hiritsu" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}