summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron Fischer2021-04-27 23:45:12 +0200
committerAaron Fischer2021-04-27 23:45:12 +0200
commitff3c7eeb76df7d5f82bcd81f109ef3d2077fa828 (patch)
tree3590c1faff2209e7ce08dda9ad6c345226e97b92 /PKGBUILD
parentc3081cd43b1d7c91c80a7166e22263b9eb910ca1 (diff)
downloadaur-hmap2.tar.gz
Add patch for recent gcc version 10.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aad3cdd04714..160f9d9a5516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,19 @@
pkgname=hmap2
pkgver=20121222
-pkgrel=1
+pkgrel=2
pkgdesc="BSP compile tools for Quake 1"
arch=(i686 x86_64)
license=("GPL")
-source=("https://icculus.org/twilight/darkplaces/files/${pkgname}build${pkgver}.zip")
-md5sums=("d99f8b76d40875d91148c9a07e46fd6c")
url="https://icculus.org/twilight/darkplaces/index.html"
+source=("https://icculus.org/twilight/darkplaces/files/${pkgname}build${pkgver}.zip"
+ "verbose-redeclared.patch")
+sha512sums=("188efbe3d7061ecdc8184e372b9f3c4bfa4047f01666a69db9effd3d46506a5b29632f29e954951a8d03fa186a4c7d66af90a2dc1d925f91a68d9cb0e4c44b9f"
+ "3380dab8f5c7d87e09516affc6a1715173cfc34887edab6fcaee8da5a5cb47c97751989277e76ac667e48ad2489c550a6d72b2d6f016b702c5dd281a5dfb629d")
+
+prepare() {
+ patch --forward --strip=1 --input="../verbose-redeclared.patch"
+}
build() {
cd "$pkgname"