summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authordusnm2020-08-21 16:37:54 +0200
committerdusnm2020-08-21 16:37:54 +0200
commit7f0be7df5f3528aba35e2041fe13f4b4f71f7fcf (patch)
treecb4fe1284b581fb0a4fa48a4b0fa9421cc600723 /PKGBUILD
downloadaur-hosts-modifier.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bfae3795a451
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Dusan Mitrovic <dusan@dusanmitrovic.xyz>
+pkgname=hosts-modifier
+pkgver=1.0.8
+pkgrel=1
+pkgdesc='A small go program used to manage the hosts file.'
+arch=('x86_64')
+url='https://github.com/BrosSquad/hosts'
+license=('GPL')
+source=('https://github.com/BrosSquad/hosts/archive/v1.0.8.tar.gz')
+makedepends=(go)
+md5sums=('1027d27526a794bc9e8f9b9177d3a3df')
+sha256sums=('1600c0513d96b5a338d41ad769d62a0da40729cae1097bcee64b3c0b8349477f')
+
+build() {
+ cd "hosts-$pkgver"
+ go build
+}
+
+package() {
+ cd "hosts-$pkgver"
+ mkdir -p "$pkgdir/usr/bin/"
+ mv hosts "$pkgdir/usr/bin/hosts"
+}