summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksey Filippov2018-03-01 17:19:17 +0000
committerAleksey Filippov2018-03-01 17:19:17 +0000
commit82442874db04f804ebdbc59dc5b9cdb7378fd355 (patch)
tree99c575518a267e7e7e70d1d5b07cbd08c46b93b5 /PKGBUILD
downloadaur-82442874db04f804ebdbc59dc5b9cdb7378fd355.tar.gz
Initial hotdoc-0.8.92
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b842c57efaf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Copyright 2018 Google LLC
+
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+
+# http://www.apache.org/licenses/LICENSE-2.0
+
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
+pkgname=hotdoc
+pkgver=0.8.92
+pkgrel=1
+epoch=
+pkgdesc="HotDoc: the tastiest API documentation system"
+arch=('any')
+url="https://github.com/hotdoc/hotdoc"
+license=('LGPL2')
+groups=()
+depends=(
+ 'python'
+ 'python-sqlalchemy'
+ 'python-yaml'
+ 'python-schema'
+ 'python-toposort'
+ 'python-lxml'
+ 'python-wheezy'
+)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/${pkgname}/${pkgname}.git#tag=${pkgver}")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}