summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Gysin2020-04-06 12:31:18 +0300
committerChristoph Gysin2020-04-06 12:31:18 +0300
commit0dc52b1732bb80417a909e36d96c7db5cc2e40c7 (patch)
tree57899cd64f17a634eb1f77f36cd7c10f13347fc3 /PKGBUILD
parent6e93d8d01c7dcaec1c1311a7910f215a5054d4fa (diff)
downloadaur-httpie-aws-authv4-git.tar.gz
add pkgver/conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbbae64996c1..c4ba4255eb61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=httpie-aws-authv4
pkgname=httpie-aws-authv4-git
-pkgver=1
+pkgver=r22.6165193
pkgrel=1
pkgdesc="AWSv4 auth plugin for HTTPie"
url="https://github.com/aidan-/httpie-aws-authv4"
@@ -12,6 +12,13 @@ source=('git+https://github.com/aidan-/httpie-aws-authv4')
sha256sums=('SKIP')
depends=('httpie' 'python-aws-requests-auth')
arch=('any')
+provides=('httpie-aws-authv4')
+conflicts=('httpie-aws-authv4')
+
+pkgver() {
+ cd $_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
build() {
cd "$srcdir/$_pkgname"